atom feed4 messages in org.apache.tomcat.usersTomcat 7 and Jakarta Mailer Taglib
FromSent OnAttachments
mraibleJul 12, 2011 10:39 am 
Konstantin KolinkoJul 12, 2011 12:45 pm 
mraibleJul 12, 2011 12:50 pm 
Konstantin KolinkoJul 12, 2011 1:29 pm 
Subject:Tomcat 7 and Jakarta Mailer Taglib
From:mraible (ma@raibledesigns.com)
Date:Jul 12, 2011 10:39:37 am
List:org.apache.tomcat.users

Hello,

I'm experiencing a strange issue trying to upgrade to Tomcat 7 on raibledesigns.com (Linux 2.4.37.9). When I hit my contact page and try to send a message, I get the following stack trace:

SEVERE: Servlet.service() for servlet [jsp] in context with path [] threw exception [The absolute uri: http://jakarta.apache.org/taglibs/mailer-1.0 cannot be resolved in either web.xml or the jar files deployed with this application] with root cause org.apache.jasper.JasperException: The absolute uri: http://jakarta.apache.org/taglibs/mailer-1.0 cannot be resolved in either web.xml or the jar files deployed with this application at org.apache.jasper.compiler.DefaultErrorHandler.jspError(DefaultErrorHandler.java:55) at org.apache.jasper.compiler.ErrorDispatcher.dispatch(ErrorDispatcher.java:409) at org.apache.jasper.compiler.ErrorDispatcher.jspError(ErrorDispatcher.java:116) at org.apache.jasper.compiler.TagLibraryInfoImpl.generateTLDLocation(TagLibraryInfoImpl.java:310) at org.apache.jasper.compiler.TagLibraryInfoImpl.<init>(TagLibraryInfoImpl.java:152) at org.apache.jasper.compiler.Parser.parseTaglibDirective(Parser.java:410) at org.apache.jasper.compiler.Parser.parseDirective(Parser.java:475) at org.apache.jasper.compiler.Parser.parseElements(Parser.java:1425) at org.apache.jasper.compiler.Parser.parse(Parser.java:138)

I've downloaded the ROOT app locally and run it with Tomcat 7 and Java 6 (on OS X) and I don't see this problem.

Any ideas?

Thanks,

Matt